libc-1.ebuild 826 B

12345678910111213141516171819202122
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Virtual for the C library"
  5. SLOT="0"
  6. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  7. # explicitly depend on SLOT 2.2 of glibc, because it sets
  8. # a different SLOT for cross-compiling
  9. # Cygwin uses newlib, which lacks libcrypt
  10. RDEPEND="!prefix-guest? (
  11. elibc_glibc? ( sys-libs/glibc:2.2 )
  12. elibc_musl? ( sys-libs/musl )
  13. elibc_uclibc? ( || ( sys-libs/uclibc-ng sys-libs/uclibc ) )
  14. elibc_FreeBSD? ( sys-freebsd/freebsd-lib )
  15. )
  16. prefix-guest? (
  17. elibc_Cygwin? ( sys-libs/cygwin-crypt )
  18. )"