nx_util-0.52.1.ebuild 937 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="sqlite"
  6. DISTUTILS_SINGLE_IMPL=true
  7. inherit distutils-r1 versionator
  8. MY_PV="$(replace_version_separator 2 '-')"
  9. DESCRIPTION="Whitelist & Reports generation for Naxsi (Web Application Firewall module for Nginx)"
  10. HOMEPAGE="https://github.com/nbs-system/naxsi"
  11. # keep the name in sync with what's in the nginx ebuild to avoid duplication
  12. SRC_URI="https://github.com/nbs-system/naxsi/archive/${MY_PV}.tar.gz -> ngx_http_naxsi-${MY_PV}.tar.gz"
  13. LICENSE="GPL-2+ Apache-2.0 CC-BY-NC-SA-3.0"
  14. SLOT="0"
  15. KEYWORDS="~amd64"
  16. IUSE=""
  17. DEPEND=""
  18. RDEPEND="www-servers/nginx[nginx_modules_http_naxsi]"
  19. PATCHES=( "${FILESDIR}/${PV}-fix-install-paths.patch" )
  20. S="${WORKDIR}/naxsi-${MY_PV}/nx_util"
  21. src_prepare() {
  22. distutils-r1_src_prepare
  23. mv nx_util{.py,} || die "renaming script failed"
  24. }