apache-2.2.31-r1.ebuild 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # latest gentoo apache files
  5. GENTOO_PATCHSTAMP="20140922"
  6. GENTOO_DEVELOPER="polynomial-c"
  7. GENTOO_PATCHNAME="gentoo-apache-2.2.29"
  8. # IUSE/USE_EXPAND magic
  9. IUSE_MPMS_FORK="itk peruser prefork"
  10. IUSE_MPMS_THREAD="event worker"
  11. IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
  12. authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
  13. authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
  14. charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio
  15. env expires ext_filter file_cache filter headers ident imagemap include info
  16. log_config log_forensic logio mem_cache mime mime_magic negotiation proxy
  17. proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi rewrite
  18. reqtimeout setenvif speling status substitute unique_id userdir usertrack
  19. version vhost_alias"
  20. # The following are also in the source as of this version, but are not available
  21. # for user selection:
  22. # bucketeer case_filter case_filter_in echo http isapi optional_fn_export
  23. # optional_fn_import optional_hook_export optional_hook_import
  24. # inter-module dependencies
  25. # TODO: this may still be incomplete
  26. MODULE_DEPENDS="
  27. dav_fs:dav
  28. dav_lock:dav
  29. deflate:filter
  30. disk_cache:cache
  31. ext_filter:filter
  32. file_cache:cache
  33. log_forensic:log_config
  34. logio:log_config
  35. mem_cache:cache
  36. mime_magic:mime
  37. proxy_ajp:proxy
  38. proxy_balancer:proxy
  39. proxy_connect:proxy
  40. proxy_ftp:proxy
  41. proxy_http:proxy
  42. proxy_scgi:proxy
  43. substitute:filter
  44. "
  45. # module<->define mappings
  46. MODULE_DEFINES="
  47. auth_digest:AUTH_DIGEST
  48. authnz_ldap:AUTHNZ_LDAP
  49. cache:CACHE
  50. dav:DAV
  51. dav_fs:DAV
  52. dav_lock:DAV
  53. disk_cache:CACHE
  54. file_cache:CACHE
  55. info:INFO
  56. ldap:LDAP
  57. mem_cache:CACHE
  58. proxy:PROXY
  59. proxy_ajp:PROXY
  60. proxy_balancer:PROXY
  61. proxy_connect:PROXY
  62. proxy_ftp:PROXY
  63. proxy_http:PROXY
  64. ssl:SSL
  65. status:STATUS
  66. suexec:SUEXEC
  67. userdir:USERDIR
  68. "
  69. # critical modules for the default config
  70. MODULE_CRITICAL="
  71. authz_host
  72. dir
  73. mime
  74. "
  75. inherit apache-2 systemd toolchain-funcs
  76. DESCRIPTION="The Apache Web Server"
  77. HOMEPAGE="https://httpd.apache.org/"
  78. # some helper scripts are Apache-1.1, thus both are here
  79. LICENSE="Apache-2.0 Apache-1.1"
  80. SLOT="2"
  81. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  82. IUSE=""
  83. PATCHES=(
  84. "${FILESDIR}/${PN}-asf-httpoxy.patch"
  85. )
  86. src_configure() {
  87. # Brain dead check.
  88. tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
  89. apache-2_src_configure
  90. }
  91. src_install() {
  92. apache-2_src_install
  93. # install apxs in /usr/bin (bug #502384) and put a symlink into the
  94. # old location until all ebuilds and eclasses have been modified to
  95. # use the new location.
  96. local apxs_dir="/usr/bin"
  97. dodir ${apxs_dir}
  98. mv "${D}"/usr/sbin/apxs "${D}"${apxs_dir} || die
  99. ln -s ../bin/apxs "${D}"/usr/sbin/apxs || die
  100. systemd_newunit "${FILESDIR}/apache2.2.service" "apache2.service"
  101. systemd_dotmpfilesd "${FILESDIR}/apache.conf"
  102. }