python-whiteboard-20101012-r1.ebuild 910 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="Build and operate a electronic whiteboard Wiimote and IR Pen"
  7. HOMEPAGE="https://github.com/pnegre/python-whiteboard"
  8. SRC_URI="https://dev.gentoo.org/~lxnay/${PN}/${P}.tar.bz2"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~x86 ~amd64"
  12. IUSE=""
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="${PYTHON_DEPS}
  15. app-misc/cwiid[python,${PYTHON_USEDEP}]
  16. dev-python/numpy[${PYTHON_USEDEP}]
  17. dev-python/pybluez[${PYTHON_USEDEP}]
  18. dev-python/PyQt4[${PYTHON_USEDEP}]
  19. dev-python/python-xlib[${PYTHON_USEDEP}]"
  20. DEPEND="${RDEPEND}"
  21. PATCHES=( "${FILESDIR}"/${PN}-20101012-fix-desktop-qa.patch )
  22. src_install() {
  23. default
  24. # install correctly in python sitedir
  25. python_domodule "${ED%/}"/usr/lib/python-whiteboard
  26. rm -r "${ED%/}"/usr/lib || die
  27. }