gmrun-0.9.2-r1.ebuild 837 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
  6. HOMEPAGE="https://sourceforge.net/projects/gmrun/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~mips ppc x86"
  11. RDEPEND="
  12. dev-libs/glib:2
  13. dev-libs/popt
  14. x11-libs/gtk+:2
  15. "
  16. DEPEND="
  17. ${RDEPEND}
  18. elibc_glibc? ( >=sys-libs/glibc-2.10 )
  19. sys-apps/sed
  20. virtual/pkgconfig
  21. "
  22. src_prepare() {
  23. epatch \
  24. "${FILESDIR}"/${P}-gcc43.patch \
  25. "${FILESDIR}"/${P}-sysconfdir.patch \
  26. "${FILESDIR}"/${P}-glibc210.patch \
  27. "${FILESDIR}"/${P}-stlport.patch
  28. eautoreconf
  29. }
  30. src_install() {
  31. emake DESTDIR="${D}" install || die "emake install failed"
  32. dodoc AUTHORS ChangeLog README NEWS
  33. }