lsw-0.3.ebuild 668 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="list window names"
  6. HOMEPAGE="http://tools.suckless.org/x/lsw"
  7. SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~x86"
  11. RDEPEND="x11-libs/libX11"
  12. DEPEND="${RDEPEND}
  13. x11-proto/xproto"
  14. src_prepare() {
  15. sed -i config.mk \
  16. -e '/^CC/d' \
  17. -e '/^CFLAGS/{s| -Os||;s|=|+=|}' \
  18. -e '/^LDFLAGS/{s|=|+=|;s| -s||}' || die
  19. sed -i \
  20. -e 's|^\t@|\t|g' \
  21. -e '/^\techo/d' \
  22. Makefile || die
  23. }
  24. src_compile() {
  25. emake CC=$(tc-getCC)
  26. }
  27. src_install() {
  28. doman ${PN}.1
  29. dobin ${PN}
  30. }