mozo-1.14.1.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="xml"
  6. inherit python-r1 mate
  7. if [[ ${PV} != 9999 ]]; then
  8. KEYWORDS="~amd64 ~arm ~x86"
  9. fi
  10. DESCRIPTION="Mozo menu editor for MATE"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. IUSE=""
  14. COMMON_DEPEND="${PYTHON_DEPS}
  15. >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
  16. >=mate-base/mate-menus-1.6[introspection]
  17. x11-libs/gdk-pixbuf:2[introspection]
  18. x11-libs/gtk+:3[introspection]
  19. virtual/libintl:0
  20. !!x11-misc/mate-menu-editor"
  21. RDEPEND="${COMMON_DEPEND}"
  22. DEPEND="${COMMON_DEPEND}
  23. >=dev-util/intltool-0.40:*
  24. sys-devel/gettext:*
  25. virtual/pkgconfig:*"
  26. src_prepare() {
  27. mate_src_prepare
  28. python_copy_sources
  29. }
  30. src_configure() {
  31. python_foreach_impl run_in_build_dir mate_src_configure \
  32. --disable-icon-update
  33. }
  34. src_compile() {
  35. python_foreach_impl run_in_build_dir default
  36. }
  37. src_test() {
  38. python_foreach_impl run_in_build_dir emake check
  39. }
  40. src_install() {
  41. installing() {
  42. mate_src_install
  43. # Massage shebang to make python_doscript happy
  44. sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
  45. -i mozo || die
  46. python_doscript mozo
  47. }
  48. python_foreach_impl run_in_build_dir installing
  49. }