whaw-0.2.ebuild 555 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="Window manager independent Window Layout tool"
  6. HOMEPAGE="http://repetae.net/computer/whaw/"
  7. SRC_URI="http://repetae.net/computer/${PN}/drop/whaw-${PV}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. RDEPEND="dev-libs/popt
  12. x11-libs/libX11
  13. x11-libs/libXinerama
  14. x11-libs/libXmu
  15. "
  16. DEPEND="${RDEPEND}"
  17. src_prepare() {
  18. epatch "${FILESDIR}/${P}-fix-implicit-declaration-warning.patch"
  19. epatch_user
  20. }