xdotool-3.20150503.1-r1.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs flag-o-matic multilib
  5. DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
  6. HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
  7. SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm ppc x86"
  11. IUSE="examples"
  12. RDEPEND="x11-libs/libXtst
  13. x11-libs/libX11
  14. x11-libs/libXinerama
  15. x11-libs/libxkbcommon"
  16. DEPEND="${RDEPEND}"
  17. # The test wants to manualy start Xvfb, wont use VirtualX and it tries
  18. # to run a full gnome-session. For such a tiny application i consider
  19. # it overkill to rewrite the test scripts to not use it's own X server
  20. # and add a full blown gnome just to run the tests.
  21. RESTRICT="test"
  22. src_prepare() {
  23. default
  24. sed -i \
  25. -e "s/installheader post-install$/installheader/" \
  26. -e 's:\<pkg-config\>:$(PKG_CONFIG):' \
  27. Makefile || die "sed failed"
  28. }
  29. src_compile() {
  30. tc-export CC LD PKG_CONFIG
  31. default
  32. }
  33. src_install() {
  34. emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install
  35. dodoc CHANGELIST README
  36. if use examples; then
  37. insinto /usr/share/doc/${PF}/examples
  38. doins examples/*
  39. fi
  40. }