xtrace-1.3.0.ebuild 759 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils
  5. MY_CODE="3694"
  6. DESCRIPTION="X11 protocol trace utility"
  7. HOMEPAGE="http://xtrace.alioth.debian.org/"
  8. SRC_URI="https://alioth.debian.org/frs/download.php/${MY_CODE}/${P/-/_}.orig.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
  12. IUSE=""
  13. DEPEND="x11-libs/libX11"
  14. RDEPEND="${DEPEND}"
  15. DOCS=(AUTHORS ChangeLog README NEWS)
  16. src_configure() {
  17. local myeconfargs=(
  18. --program-transform-name="s/^x/x11/"
  19. )
  20. autotools-utils_src_configure
  21. }
  22. pkg_postinst () {
  23. einfo "To avoid collision with glibc (/usr/bin/xtrace)"
  24. einfo "binary was renamed to x11trace, as suggested by author"
  25. }