libxfce4util-4.12.1-r1.ebuild 802 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="A basic utility library for the Xfce desktop environment"
  6. HOMEPAGE="http://www.xfce.org/projects/"
  7. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="LGPL-2"
  9. SLOT="0/7"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
  11. IUSE="debug"
  12. RDEPEND=">=dev-libs/glib-2.24"
  13. DEPEND="${RDEPEND}
  14. dev-util/intltool
  15. dev-util/gtk-doc-am
  16. sys-devel/gettext
  17. virtual/pkgconfig"
  18. pkg_setup() {
  19. XFCONF=(
  20. $(xfconf_use_debug)
  21. )
  22. [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
  23. DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
  24. }