xfce4-alsa-plugin-0.1.1.ebuild 754 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
  5. PYTHON_REQ_USE='threads(+)' # required by waf
  6. inherit python-any-r1 vala waf-utils
  7. DESCRIPTION="Simple ALSA volume control for xfce4-panel"
  8. HOMEPAGE="https://github.com/equeim/xfce4-alsa-plugin"
  9. SRC_URI="https://github.com/equeim/${PN}/archive/0.1.1.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~arm64 ~x86"
  13. IUSE=""
  14. RDEPEND="
  15. media-libs/alsa-lib
  16. xfce-base/xfce4-panel
  17. x11-libs/gtk+:2
  18. "
  19. DEPEND="${RDEPEND}
  20. ${PYTHON_DEPS}
  21. $(vala_depend)
  22. dev-util/intltool
  23. "
  24. pkg_setup() { python-any-r1_pkg_setup; }
  25. src_prepare() {
  26. vala_src_prepare --ignore-use
  27. eapply_user
  28. }