xfce4-mount-plugin-0.6.7.ebuild 743 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="An mount plug-in for the Xfce panel"
  6. HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-mount-plugin"
  7. SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
  11. IUSE="debug"
  12. RDEPEND=">=xfce-base/libxfce4ui-4.10
  13. >=xfce-base/xfce4-panel-4.10"
  14. DEPEND="${RDEPEND}
  15. dev-util/intltool
  16. sys-devel/gettext
  17. virtual/pkgconfig"
  18. pkg_setup() {
  19. PATCHES=( "${FILESDIR}"/${P}-LINGUAS.patch )
  20. XFCONF=(
  21. $(xfconf_use_debug)
  22. )
  23. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  24. }