xfce4-notes-plugin-1.8.1.ebuild 808 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit versionator xfconf
  5. DESCRIPTION="Xfce4 panel sticky notes plugin"
  6. HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
  7. SRC_URI="mirror://xfce/src/panel-plugins/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/glib-2.24:2=
  13. >=x11-libs/gtk+-2.20:2=
  14. >=xfce-base/libxfce4ui-4.10:=
  15. >=xfce-base/libxfce4util-4.10:=
  16. >=xfce-base/xfce4-panel-4.10:=
  17. >=xfce-base/xfconf-4.10:=
  18. dev-libs/libunique:1="
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig
  21. dev-util/intltool"
  22. pkg_setup() {
  23. DOCS=( AUTHORS ChangeLog NEWS README )
  24. }