btrbk-0.25.0.ebuild 732 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit systemd
  5. if [[ ${PV} == "9999" ]] ; then
  6. EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
  7. inherit git-r3
  8. SRC_URI=""
  9. KEYWORDS=""
  10. else
  11. SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
  12. KEYWORDS="~amd64 ~arm ~x86"
  13. fi
  14. DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
  15. HOMEPAGE="https://digint.ch/btrbk/"
  16. LICENSE="GPL-3+"
  17. SLOT="0"
  18. IUSE="+pv"
  19. DEPEND=""
  20. RDEPEND="dev-lang/perl
  21. net-misc/openssh
  22. pv? ( sys-apps/pv )
  23. >=sys-fs/btrfs-progs-3.18.2"
  24. src_install() {
  25. emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
  26. }