bup-0.29.1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="A highly efficient backup system based on the git packfile format"
  7. HOMEPAGE="https://bup.github.io/ https://github.com/bup/bup"
  8. SRC_URI="https://github.com/bup/bup/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="LGPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="+doc test web"
  13. RDEPEND="${PYTHON_DEPS}
  14. app-arch/par2cmdline
  15. dev-python/fuse-python[${PYTHON_USEDEP}]
  16. dev-python/pylibacl[${PYTHON_USEDEP}]
  17. dev-python/pyxattr[${PYTHON_USEDEP}]
  18. web? ( www-servers/tornado[${PYTHON_USEDEP}] )
  19. sys-libs/readline:0
  20. dev-vcs/git"
  21. DEPEND="${RDEPEND}
  22. test? (
  23. dev-lang/perl
  24. net-misc/rsync
  25. )
  26. doc? ( app-text/pandoc )
  27. "
  28. # unresolved sandbox issues
  29. RESTRICT="test"
  30. src_prepare() {
  31. default
  32. sed -e "/^CFLAGS :=/s/-O2 -Werror//" \
  33. -i Makefile || die
  34. }
  35. src_configure() {
  36. # only build/install docs if enabled
  37. export PANDOC=$(usex doc pandoc "")
  38. ./configure || die
  39. }
  40. src_test() {
  41. emake test
  42. }
  43. src_install() {
  44. emake DESTDIR="${D}" PREFIX=/usr LIBDIR="/usr/$(get_libdir)/bup" DOCDIR="/usr/share/${PF}" install
  45. python_fix_shebang "${ED}"
  46. python_optimize "${ED}"
  47. }