rsnapshot-1.3.1-r2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A filesystem backup utility based on rsync"
  6. HOMEPAGE="http://www.rsnapshot.org"
  7. SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
  11. IUSE=""
  12. RDEPEND=">=dev-lang/perl-5.8.2
  13. dev-perl/Lchown
  14. >=sys-apps/util-linux-2.12-r4
  15. >=sys-apps/coreutils-5.0.91-r4
  16. >=net-misc/openssh-3.7.1_p2-r1
  17. >=net-misc/rsync-2.6.0"
  18. DEPEND="${RDEPEND}"
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${P}-cp_al.patch \
  21. "${FILESDIR}"/${P}-perl518.patch
  22. }
  23. src_install() {
  24. # Change sysconfdir to install the template file as documentation
  25. # rather than in /etc.
  26. emake install DESTDIR="${D}" \
  27. sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
  28. dodoc README AUTHORS TODO ChangeLog \
  29. docs/Upgrading_from_1.1 \
  30. docs/HOWTOs/rsnapshot-{Mac,windows}-howto
  31. docinto utils
  32. dodoc utils/{README,rsnaptar,*.sh,*.pl}
  33. docinto utils/rsnapshotdb
  34. dodoc utils/rsnapshotdb/*
  35. }
  36. pkg_postinst() {
  37. elog "The template configuration file has been installed as"
  38. elog "/usr/share/doc/${PF}/rsnapshot.conf.default"
  39. elog "Copy and edit the the above file as /etc/rsnapshot.conf"
  40. }