rsnapshot-1.4.2.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A filesystem backup utility based on rsync"
  5. HOMEPAGE="http://www.rsnapshot.org"
  6. SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
  7. SLOT="0"
  8. LICENSE="GPL-2"
  9. KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
  10. RDEPEND=">=dev-lang/perl-5.8.2
  11. dev-perl/Lchown
  12. >=sys-apps/util-linux-2.12-r4
  13. >=sys-apps/coreutils-5.0.91-r4
  14. >=net-misc/openssh-3.7.1_p2-r1
  15. >=net-misc/rsync-2.6.0"
  16. DEPEND="${RDEPEND}"
  17. src_prepare() {
  18. default
  19. # remove '/etc/' since we don't place it here, bug #461554
  20. sed -i -e 's:/etc/rsnapshot.conf.default:rsnapshot.conf.default:' rsnapshot-program.pl || die
  21. }
  22. src_install() {
  23. docompress -x "/usr/share/doc/${PF}/rsnapshot.conf.default"
  24. # Change sysconfdir to install the template file as documentation
  25. # rather than in /etc.
  26. emake install DESTDIR="${D}" \
  27. sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
  28. dodoc README.md AUTHORS ChangeLog \
  29. docs/Upgrading_from_1.1
  30. docinto utils
  31. dodoc utils/{README,rsnaptar,*.sh,*.pl}
  32. docinto utils/rsnapshotdb
  33. dodoc utils/rsnapshotdb/*
  34. }
  35. pkg_postinst() {
  36. elog "The template configuration file has been installed as"
  37. elog " /usr/share/doc/${PF}/rsnapshot.conf.default"
  38. elog "Copy and edit the the above file as /etc/rsnapshot.conf"
  39. }