snapper-9999.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGIT_REPO_URI="git://github.com/openSUSE/snapper.git"
  5. AUTOTOOLS_AUTORECONF=1
  6. AUTOTOOLS_IN_SOURCE_BUILD=1
  7. inherit eutils autotools-utils git-r3
  8. DESCRIPTION="Command-line program for btrfs and ext4 snapshot management"
  9. HOMEPAGE="http://snapper.io/"
  10. SRC_URI=""
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS=""
  14. IUSE="+btrfs ext4 lvm pam xattr"
  15. RDEPEND="dev-libs/boost:=[threads]
  16. dev-libs/libxml2
  17. dev-libs/icu:=
  18. sys-apps/acl
  19. sys-apps/dbus
  20. sys-apps/util-linux
  21. sys-libs/zlib
  22. virtual/libintl
  23. btrfs? ( >=sys-fs/btrfs-progs-3.17.1 )
  24. ext4? ( sys-fs/e2fsprogs )
  25. lvm? ( sys-fs/lvm2 )
  26. pam? ( sys-libs/pam )
  27. xattr? ( sys-apps/attr )"
  28. DEPEND="${RDEPEND}
  29. sys-devel/gettext
  30. virtual/pkgconfig"
  31. REQUIRED_USE="|| ( btrfs ext4 lvm )"
  32. DOCS=( AUTHORS package/snapper.changes )
  33. PATCHES=( "${FILESDIR}"/cron-confd.patch )
  34. src_configure() {
  35. local myeconfargs=(
  36. --with-conf="/etc/conf.d"
  37. --docdir="/usr/share/doc/${PF}"
  38. --disable-zypp
  39. --enable-rollback
  40. $(use_enable btrfs)
  41. $(use_enable ext4)
  42. $(use_enable lvm)
  43. $(use_enable pam)
  44. $(use_enable xattr xattrs)
  45. )
  46. autotools-utils_src_configure
  47. }
  48. src_install() {
  49. autotools-utils_src_install
  50. # Existing configuration file required to function
  51. newconfd data/sysconfig.snapper snapper
  52. }
  53. pkg_postinst() {
  54. elog "In order to use Snapper, you need to set up"
  55. elog "at least one config first. To do this, run:"
  56. elog "snapper create-config <subvolume>"
  57. elog "For more information, see man (8) snapper or"
  58. elog "http://snapper.io/documentation.html"
  59. }