gxemul-0.6.0-r1.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types"
  6. HOMEPAGE="http://gxemul.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/project/gxemul/GXemul/${PV}/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
  11. IUSE="debug X"
  12. RDEPEND="X? ( x11-libs/libX11 )"
  13. DEPEND="${RDEPEND}
  14. X? ( x11-proto/xproto )"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${PV}-gcc46.patch
  17. epatch "${FILESDIR}"/${PV}-fix-mymkstemp.patch # Bug 441558
  18. epatch "${FILESDIR}"/${PV}-fix-mkstemp-test.patch # Bug 441558
  19. sed -i configure -e 's|-O3||g' || die "sed configure"
  20. tc-export CC CXX
  21. }
  22. src_configure() {
  23. # no autotools
  24. ./configure \
  25. --disable-valgrind \
  26. $(use debug && echo --debug) \
  27. $(use X || echo --disable-x) || die "configure failed"
  28. }
  29. src_install() {
  30. dobin gxemul
  31. doman man/gxemul.1
  32. dodoc HISTORY README
  33. dohtml -r doc/*
  34. }