rex-client-9999.ebuild 799 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Remote EXexcution agent"
  5. HOMEPAGE="http://mduft.github.io/rex/"
  6. if [[ ${PV} == 9999 ]]; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://github.com/mduft/rex.git"
  9. else
  10. SRC_URI=""
  11. KEYWORDS="~x86-linux"
  12. fi
  13. LICENSE="MIT"
  14. SLOT="0"
  15. IUSE=""
  16. REX_EXE=(
  17. "client/rex-exec.sh"
  18. "client/rex-register.sh"
  19. "client/rex-paths.sh"
  20. "client/rex-remote-pconv.sh"
  21. "client/winpath2unix"
  22. "client/unixpath2win"
  23. )
  24. src_prepare() {
  25. for x in ${REX_EXE[@]}; do
  26. sed \
  27. -e "s,\. \${HOME}/rex-config.sh,\. ${EPREFIX}/etc/rex.conf,g" \
  28. -i "${x}" || die
  29. done
  30. }
  31. src_install() {
  32. for x in ${REX_EXE[@]}; do
  33. dobin "${S}"/${x}
  34. done
  35. insinto /etc
  36. newins client/rex-config.sh rex.conf
  37. }