mepl-0.45.ebuild 705 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="Self-employed-mode software for 3COM/USR message modems"
  5. HOMEPAGE="http://www.hof-berlin.de/mepl/"
  6. SRC_URI="http://www.hof-berlin.de/mepl/mepl${PV}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc x86"
  10. IUSE=""
  11. DEPEND=""
  12. S=${WORKDIR}/${PN}${PV}
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}/gcc433.patch"
  17. }
  18. src_compile() {
  19. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DMEPLCONFIG=\\\"/etc/mepl.conf\\\"\
  20. ${LDFLAGS}" en || die
  21. }
  22. src_install() {
  23. dobin mepl meplmail || die
  24. insinto /etc
  25. doins mepl.conf
  26. newman mepl.en mepl.7
  27. }