cobex-0.2.13.ebuild 677 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="small implementation of Obex for phones using the DCU-11 USB-to-serial adapter"
  5. HOMEPAGE="http://cobex.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/cobex/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc x86"
  10. IUSE=""
  11. DEPEND="dev-libs/libezV24
  12. dev-libs/expat"
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/${P}-build.patch
  17. local f
  18. for f in get ls mkdir put rm ; do mv ${f}.c cobex_${f}.c || die ; done
  19. }
  20. src_install() {
  21. dobin cobex_{ls,mkdir,put,rm} || die
  22. dodoc Changelog README Things_to_know_T310.txt
  23. }