dfu-util-0.7.ebuild 831 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. if [[ ${PV} == "9999" ]] ; then
  5. EGIT_REPO_URI="git://git.openezx.org/dfu-util.git"
  6. inherit autotools git-2
  7. SRC_URI=""
  8. #KEYWORDS=""
  9. else
  10. SRC_URI="http://dfu-util.gnumonks.org/releases/${P}.tar.gz"
  11. KEYWORDS="~amd64 ~x86"
  12. fi
  13. DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
  14. HOMEPAGE="http://wiki.openmoko.org/wiki/Dfu-util"
  15. LICENSE="GPL-2"
  16. SLOT="0"
  17. IUSE=""
  18. RDEPEND="virtual/libusb:1"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. src_prepare() {
  22. if [[ ${PV} == "9999" ]] ; then
  23. git-2_src_prepare
  24. eautoreconf
  25. fi
  26. sed -i '/^bin_PROGRAMS/s:dfu-util_static[^ ]*::' src/Makefile.in
  27. }
  28. src_install() {
  29. emake DESTDIR="${D}" install || die
  30. dodoc ChangeLog README TODO
  31. }