123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- DESCRIPTION="Converter for Microsoft Word, Excel, PowerPoint and RTF files to text"
- HOMEPAGE="http://www.wagner.pp.ru/~vitus/software/catdoc/"
- SRC_URI="http://ftp.wagner.pp.ru/pub/${PN}/${P}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 ~arm ~ppc x86 ~amd64-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
- IUSE="tk"
- DEPEND="tk? ( >=dev-lang/tk-8.1 )"
- DOCS="CODING.STD NEWS README TODO"
- # CREDITS missing by accident in catdoc-0.95
- PATCHES=(
- "${FILESDIR}/${P}-parallel-make.patch"
- )
- src_prepare() {
- default
- # Fix for case-insensitive filesystems
- echo ".PHONY: all install clean distclean dist" >> Makefile.in || die
- mv configure.{in,ac} || die
- }
- src_configure() {
- econf --with-install-root="${D}" \
- $(use_with tk wish "${EPREFIX}"/usr/bin/wish) \
- $(use_enable tk wordview)
- }
- src_compile() {
- emake LIB_DIR="${EPREFIX}"/usr/share/catdoc
- }
- src_install() {
- default
- if [[ -e ${ED}/usr/bin/xls2csv ]]; then
- einfo "Renaming xls2csv to xls2csv-${PN} because of bug 314657."
- mv -vf "${ED}"/usr/bin/xls2csv "${ED}"/usr/bin/xls2csv-${PN} || die
- fi
- }
|