libodfgen-0.1.6.ebuild 885 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/libodfgen"
  5. [[ ${PV} == 9999 ]] && inherit autotools git-r3
  6. DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
  7. HOMEPAGE="http://libwpd.sf.net"
  8. [[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
  9. LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
  10. SLOT="0"
  11. [[ ${PV} == 9999 ]] || \
  12. KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
  13. IUSE="doc"
  14. RDEPEND="
  15. dev-libs/librevenge
  16. "
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. doc? ( app-doc/doxygen )
  20. "
  21. src_prepare() {
  22. default
  23. [[ ${PV} == 9999 ]] && eautoreconf
  24. }
  25. src_configure() {
  26. econf \
  27. --disable-static \
  28. --disable-werror \
  29. --with-sharedptr=c++11 \
  30. $(use_with doc docs)
  31. }
  32. src_install() {
  33. default
  34. find "${D}" -name '*.la' -delete || die
  35. }