ocrad-0.22.ebuild 755 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit unpacker toolchain-funcs
  5. DESCRIPTION="GNU Ocrad is an OCR (Optical Character Recognition) program"
  6. HOMEPAGE="https://www.gnu.org/software/ocrad/ocrad.html"
  7. SRC_URI="mirror://nongnu/${PN}/${P}.tar.lz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 ppc ~ppc64 sparc x86"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND="$(unpacker_src_uri_depends)"
  14. DOCS="AUTHORS ChangeLog NEWS README"
  15. src_configure() {
  16. # ./configure is not based on autotools
  17. ./configure \
  18. CPPFLAGS="${CPPFLAGS}" \
  19. CXX="$(tc-getCXX)" \
  20. CXXFLAGS="${CXXFLAGS}" \
  21. LDFLAGS="${LDFLAGS}" \
  22. --prefix=/usr
  23. }
  24. src_install() {
  25. default
  26. doman doc/${PN}.1
  27. doinfo doc/${PN}.info
  28. }