par-1.52.ebuild 727 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs
  4. MY_P="Par${PV/./}"
  5. DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
  6. HOMEPAGE="http://www.nicemice.net/par/"
  7. SRC_URI="http://www.nicemice.net/par/${MY_P/./}.tar.gz"
  8. LICENSE="freedist"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE=""
  12. DEPEND="!dev-util/par
  13. !app-arch/par"
  14. S=${WORKDIR}/${MY_P}
  15. src_compile() {
  16. make -f protoMakefile CC="$(tc-getCC) -c $CFLAGS" \
  17. LINK1="$(tc-getCC) $LDFLAGS" || die 'make failed'
  18. }
  19. src_install() {
  20. newbin par par-format || die
  21. doman par.1
  22. dodoc releasenotes par.doc
  23. }