silvercity-0.9.7-r1.ebuild 923 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1 eutils
  6. MY_PN="SilverCity"
  7. MY_P="${MY_PN}-${PV}"
  8. DESCRIPTION="A lexical analyser for many languages"
  9. HOMEPAGE="http://silvercity.sourceforge.net/"
  10. SRC_URI="mirror://sourceforge/silvercity/${MY_P}.tar.gz"
  11. LICENSE="BSD"
  12. SLOT="0"
  13. KEYWORDS="~alpha amd64 ~ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  14. IUSE=""
  15. DEPEND=""
  16. RDEPEND=""
  17. S="${WORKDIR}/${MY_P}"
  18. python_prepare_all() {
  19. # Fix line endings.
  20. find -type f -exec sed -e 's/\r$//' -i {} + || die "sed failed"
  21. # Fix permissions.
  22. chmod -x CSS/default.css || die "chmod failed"
  23. # Fix shebang.
  24. sed -e 's:#!/usr/home/sweetapp/bin/python:#!/usr/bin/env python:' \
  25. -i PySilverCity/Scripts/cgi-styler-form.py || die "sed failed"
  26. distutils-r1_python_prepare_all
  27. }