ttf2pk2-2.0_p20150521.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic toolchain-funcs
  5. DESCRIPTION="Freetype 2 based TrueType font to TeX's PK format converter"
  6. HOMEPAGE="http://tug.org/texlive/"
  7. SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 ~s390 ~sh x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. IUSE=""
  12. # Note about blockers: it is a freetype2 based replacement for ttf2pk and
  13. # ttf2tfm from freetype1, so block freetype1.
  14. # It installs some data that collides with
  15. # dev-texlive/texlive-langcjk-2011[source]. Hope it'd be fixed with 2012,
  16. # meanwhile we can start dropping freetype1.
  17. RDEPEND=">=dev-libs/kpathsea-6.2.1
  18. media-libs/freetype:2
  19. sys-libs/zlib
  20. !media-libs/freetype:1
  21. !=dev-texlive/texlive-langcjk-2011*[source]"
  22. DEPEND="${RDEPEND}
  23. app-arch/xz-utils
  24. virtual/pkgconfig"
  25. S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
  26. src_configure() {
  27. has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
  28. econf --with-system-kpathsea \
  29. --with-system-freetype2 \
  30. --with-system-zlib
  31. }
  32. src_install() {
  33. emake DESTDIR="${D}" install
  34. dodoc BUGS README TODO ChangeLog
  35. }