wscr-1.2-r1.ebuild 600 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="A Lightweight and Fast Anagram Solver"
  6. HOMEPAGE="https://www.gentoo.org/"
  7. SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.gz"
  8. LICENSE="public-domain"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~mips ppc x86"
  11. IUSE=""
  12. RDEPEND="sys-apps/miscfiles"
  13. src_prepare() {
  14. sed -i 's#"/usr/dict/words";#"/usr/share/dict/words";#' wscr.h || die
  15. }
  16. src_compile() {
  17. emake CC="$(tc-getCC)" FLAGS="${CFLAGS} ${LDFLAGS}"
  18. }
  19. src_install() {
  20. dobin wscr
  21. doman wscr.6
  22. dodoc README
  23. }