qttest-4.8.7.ebuild 934 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit qt4-build-multilib
  5. DESCRIPTION="The QtTest module for unit testing Qt applications and libraries"
  6. if [[ ${QT4_BUILD_TYPE} == release ]]; then
  7. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
  8. fi
  9. IUSE=""
  10. DEPEND="
  11. ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
  12. "
  13. RDEPEND="${DEPEND}"
  14. QT4_TARGET_DIRECTORIES="src/testlib"
  15. multilib_src_configure() {
  16. local myconf=(
  17. -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor
  18. -no-xinerama -no-xshape -no-sm -no-opengl
  19. -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
  20. -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
  21. -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
  22. -no-accessibility -no-fontconfig -no-glib -no-svg
  23. )
  24. qt4_multilib_src_configure
  25. }