qttest-5.7.1.ebuild 496 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. QT5_MODULE="qtbase"
  5. VIRTUALX_REQUIRED="test"
  6. inherit qt5-build
  7. DESCRIPTION="Unit testing library for the Qt5 framework"
  8. if [[ ${QT5_BUILD_TYPE} == release ]]; then
  9. KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
  10. fi
  11. IUSE=""
  12. RDEPEND="
  13. ~dev-qt/qtcore-${PV}
  14. "
  15. DEPEND="${RDEPEND}
  16. test? (
  17. ~dev-qt/qtgui-${PV}
  18. ~dev-qt/qtxml-${PV}
  19. )
  20. "
  21. QT5_TARGET_SUBDIRS=(
  22. src/testlib
  23. )