beathazardultra-20130308-r1.ebuild 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # TODO: unbundle allegro[gtk...] (no multilib on amd64 and 5.0.9 soname)
  4. EAPI=6
  5. inherit eutils unpacker
  6. DESCRIPTION="Intense music-driven arcade shooter powered by your music"
  7. HOMEPAGE="http://www.coldbeamgames.com/"
  8. SRC_URI="beathazard-installer_03-08-13"
  9. LICENSE="all-rights-reserved"
  10. SLOT="0"
  11. KEYWORDS="-* ~amd64 ~x86"
  12. IUSE="bundled-libs"
  13. RESTRICT="bindist fetch splitdebug"
  14. QA_PREBUILT="/opt/${PN}/BeatHazard_Linux2
  15. /opt/${PN}/hge_lib/*"
  16. DEPEND="app-arch/unzip"
  17. RDEPEND="
  18. virtual/opengl
  19. amd64? (
  20. !bundled-libs? (
  21. >=media-libs/libpng-1.2.51:1.2[abi_x86_32(-)]
  22. >=virtual/jpeg-0-r2[abi_x86_32(-)]
  23. )
  24. >=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)]
  25. >=virtual/opengl-7.0-r1[abi_x86_32(-)]
  26. >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
  27. >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
  28. >=x11-libs/libXinerama-1.1.3[abi_x86_32(-)]
  29. >=x11-libs/libXrandr-1.4.2[abi_x86_32(-)]
  30. )
  31. x86? (
  32. x11-libs/gtk+:2
  33. x11-libs/libX11
  34. x11-libs/libXcursor
  35. x11-libs/libXinerama
  36. x11-libs/libXrandr
  37. !bundled-libs? (
  38. media-libs/libpng:1.2
  39. virtual/jpeg
  40. )
  41. )"
  42. S=${WORKDIR}/data
  43. pkg_nofetch() {
  44. einfo "Please buy & download ${SRC_URI} from:"
  45. einfo " ${HOMEPAGE}"
  46. einfo "and move it to ${DISTDIR}"
  47. einfo
  48. }
  49. src_unpack() {
  50. unpack_zip ${A}
  51. }
  52. src_prepare() {
  53. if ! use bundled-libs ; then
  54. einfo "Removing bundled libs..."
  55. rm -v all/hge_lib/libjpeg.so* all/hge_lib/libpng12.so* || die
  56. fi
  57. }
  58. src_install() {
  59. insinto /opt/${PN}
  60. doins -r all/*
  61. dodoc Linux.README
  62. newicon SmileLogo.png ${PN}.png
  63. make_desktop_entry ${PN}
  64. make_wrapper ${PN} "./BeatHazard_Linux2" "/opt/${PN}" "/opt/${PN}/hge_lib"
  65. fperms +x /opt/${PN}/BeatHazard_Linux2
  66. }