mutantstorm-demo-1.33-r1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils unpacker
  5. DESCRIPTION="shoot through crazy psychedelic 3D environments"
  6. HOMEPAGE="http://www.pompomgames.com/"
  7. SRC_URI="ftp://ggdev-1.homelan.com/mutantstorm/MutantStormDemo_${PV/./_}.sh.bin"
  8. LICENSE="POMPOM"
  9. SLOT="0"
  10. KEYWORDS="-* ~amd64 ~x86"
  11. IUSE=""
  12. RESTRICT="strip"
  13. RDEPEND="
  14. media-libs/libsdl[abi_x86_32(-)]
  15. sys-libs/lib-compat
  16. x11-libs/libX11[abi_x86_32(-)]
  17. x11-libs/libXext[abi_x86_32(-)]
  18. virtual/opengl[abi_x86_32(-)]"
  19. S=${WORKDIR}
  20. dir=/opt/${PN}
  21. Ddir=${D}/${dir}
  22. QA_PREBUILT="${dir:1}/mutantstorm-bin"
  23. src_install() {
  24. insinto "${dir}"
  25. doins -r menu script styles
  26. exeinto "${dir}"
  27. doexe bin/Linux/x86/*
  28. # Remove libSDL since we use the system version and our version doesn't
  29. # have TEXTRELs in it.
  30. rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
  31. make_wrapper mutantstorm-demo ./mutantstormdemo "${dir}" "${dir}"
  32. insinto "${dir}"
  33. doins README.txt buy_me mutant.xpm pompom readme.htm
  34. }