mutantstorm-demo-1.33.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils unpacker games
  5. DESCRIPTION="shoot through crazy psychedelic 3D environments"
  6. HOMEPAGE="http://www.pompomgames.com/"
  7. SRC_URI="ftp://ggdev-1.homelan.com/mutantstorm/MutantStormDemo_${PV/./_}.sh.bin"
  8. LICENSE="POMPOM"
  9. SLOT="0"
  10. KEYWORDS="-* amd64 x86"
  11. IUSE=""
  12. RESTRICT="strip"
  13. RDEPEND="sys-libs/lib-compat
  14. media-libs/libsdl[abi_x86_32(-)]
  15. x11-libs/libX11[abi_x86_32(-)]
  16. x11-libs/libXext[abi_x86_32(-)]
  17. virtual/opengl[abi_x86_32(-)]"
  18. S=${WORKDIR}
  19. dir=${GAMES_PREFIX_OPT}/${PN}
  20. Ddir=${D}/${dir}
  21. QA_PREBUILT="${dir:1}/mutantstorm-bin"
  22. src_install() {
  23. insinto "${dir}"
  24. doins -r menu script styles
  25. exeinto "${dir}"
  26. doexe bin/Linux/x86/*
  27. # Remove libSDL since we use the system version and our version doesn't
  28. # have TEXTRELs in it.
  29. rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
  30. games_make_wrapper mutantstorm-demo ./mutantstormdemo "${dir}" "${dir}"
  31. insinto "${dir}"
  32. doins README.txt buy_me mutant.xpm pompom readme.htm
  33. prepgamesdirs
  34. }