ezquake-bin-2.2.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games
  5. MY_FULL_PV=1.9.3
  6. MY_PN="${PN/-bin/}"
  7. DESCRIPTION="Quakeworld client with mqwcl functionality and many more features"
  8. HOMEPAGE="http://ezquake.sf.net/"
  9. SRC_URI="
  10. amd64? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_64.${MY_FULL_PV}.tar.gz
  11. mirror://sourceforge/${MY_PN}/${MY_PN}_linux64_${PV}.tar.gz )
  12. x86? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_${MY_FULL_PV}.tar.gz
  13. mirror://sourceforge/${MY_PN}/${MY_PN}_linux32_${PV}.tar.gz )"
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. KEYWORDS="~amd64 ~x86"
  17. RESTRICT="strip mirror"
  18. IUSE="cdinstall"
  19. DEPEND="cdinstall? ( games-fps/quake1-data )"
  20. RDEPEND="${DEPEND}
  21. virtual/opengl
  22. x11-libs/libXxf86dga
  23. x11-libs/libXxf86vm"
  24. S=${WORKDIR}/${MY_PN}
  25. dir=${GAMES_PREFIX_OPT}/${PN}
  26. QA_PREBUILT="${dir:1}/ezquake*"
  27. src_unpack() {
  28. unpack ${A}
  29. if use amd64; then
  30. mv ${MY_PN}_linux-x86_64.${MY_FULL_PV} "${MY_PN}"
  31. mv ezquake-gl_linux-x64.glx "${MY_PN}"/ezquake-gl.glx
  32. else
  33. mv ${MY_PN}_linux-x86.${MY_FULL_PV} "${MY_PN}"
  34. mv ezquake-gl_linux-x86.glx "${MY_PN}"/ezquake-gl.glx
  35. fi
  36. }
  37. src_install() {
  38. exeinto "${dir}"
  39. insinto "${dir}"
  40. doexe ezquake-gl.glx
  41. doins -r ezquake qw
  42. dosym "${GAMES_DATADIR}"/quake1/id1 "${dir}"/id1
  43. games_make_wrapper ezquake-gl.glx ./ezquake-gl.glx "${dir}" "${dir}"
  44. prepgamesdirs
  45. }
  46. pkg_postinst() {
  47. games_pkg_postinst
  48. if ! use cdinstall; then
  49. elog "NOTE that this client doesn't include .pak files. You *should*"
  50. elog "enable \"cdinstall\" flag or install quake1-demodata with the symlink use flag."
  51. elog "You can also copy the files from your Quake1 CD to"
  52. elog " ${dir}/quake1/id1 (all names lowercase)"
  53. elog ""
  54. elog "You may also want to check:"
  55. elog " http://fuhquake.quakeworld.nu - complete howto on commands and variables"
  56. elog " http://equake.quakeworld.nu - free package containing various files"
  57. fi
  58. }