ngstar-2.1.8-r2.ebuild 895 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="NGStar is a clone of a HP48 game called dstar"
  6. HOMEPAGE="http://freshmeat.net/projects/ngstar"
  7. SRC_URI="mirror://gentoo//${P}-src.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="sys-libs/ncurses:0
  13. sys-libs/gpm"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig"
  16. src_prepare() {
  17. epatch \
  18. "${FILESDIR}"/${P}-gentoo-path.patch \
  19. "${FILESDIR}"/${P}-gcc43.patch \
  20. "${FILESDIR}"/${P}-gcc47.patch \
  21. "${FILESDIR}"/${P}-ldflags.patch
  22. sed -i \
  23. -e "s:@GENTOO_DATA@:${GAMES_DATADIR}:" \
  24. -e "s:@GENTOO_BIN@:${GAMES_BINDIR}:" \
  25. -e "/^CPPFLAGS/s:+=:+= ${CXXFLAGS}:" \
  26. -e "/SILENT/d" \
  27. configure || die
  28. }
  29. src_configure() {
  30. ./configure \
  31. --prefix "" \
  32. --without-fltk2 || die
  33. }
  34. src_install() {
  35. default
  36. prepgamesdirs
  37. }