rezerwar-0.4.2.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="Puzzle game like the known tetromino and the average pipe games"
  6. HOMEPAGE="http://tamentis.com/projects/rezerwar/"
  7. SRC_URI="http://tamentis.com/projects/rezerwar/files/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND="media-libs/libsdl[sound,joystick,video]
  13. media-libs/sdl-mixer[vorbis]"
  14. RDEPEND="${DEPEND}"
  15. src_prepare() {
  16. sed -i \
  17. -e '/check_sdl$/d' \
  18. -e 's/-O2 //' \
  19. configure \
  20. || die 'sed failed'
  21. sed -i \
  22. -e '/CC.*OBJECTS/s:$(CC):$(CC) $(LDFLAGS):' \
  23. mkfiles/Makefile.src \
  24. || die "sed failed"
  25. }
  26. src_configure() {
  27. SDLCONFIG=sdl-config \
  28. TARGET_BIN="${GAMES_BINDIR}" \
  29. TARGET_DOC=/usr/share/doc/${PF} \
  30. TARGET_DATA="${GAMES_DATADIR}/${PN}" \
  31. ./configure \
  32. || die "configure failed"
  33. sed -i \
  34. -e '/TARGET_DOC/d' \
  35. Makefile \
  36. || die "sed failed"
  37. }
  38. src_install() {
  39. dodir "${GAMES_BINDIR}"
  40. default
  41. dodoc doc/{CHANGES,README,TODO}
  42. make_desktop_entry rezerwar Rezerwar
  43. prepgamesdirs
  44. }