xtris-1.15.ebuild 785 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs games
  5. DESCRIPTION="a networked Tetris-like game"
  6. HOMEPAGE="http://www.iagora.com/~espel/xtris/xtris.html"
  7. SRC_URI="http://www.iagora.com/~espel/xtris/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="x11-libs/libX11"
  13. RDEPEND="${DEPEND}"
  14. S=${WORKDIR}/${PN}
  15. src_compile() {
  16. emake \
  17. CC=$(tc-getCC) \
  18. BINDIR="${GAMES_BINDIR}" \
  19. MANDIR=/usr/share/man \
  20. CFLAGS="${CFLAGS}" \
  21. EXTRALIBS="${LDFLAGS}"
  22. }
  23. src_install() {
  24. dogamesbin xtris xtserv xtbot
  25. doicon "${FILESDIR}"/${PN}.xpm
  26. make_desktop_entry ${PN} xtris ${PN}
  27. doman xtris.6 xtserv.6 xtbot.6
  28. dodoc ChangeLog PROTOCOL README
  29. prepgamesdirs
  30. }