biounzip-1.1a.ebuild 586 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Unpacks BioZip archives"
  6. HOMEPAGE="http://biounzip.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/biounzip/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND="sys-libs/zlib"
  13. RDEPEND=${DEPEND}
  14. S=${WORKDIR}/${P/a/}
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${P}-64bit.patch
  17. }
  18. src_compile() {
  19. $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
  20. }
  21. src_install() {
  22. dobin ${PN}
  23. dodoc biozip.txt
  24. }