docky-2.2.1.1-r1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils gnome2 mono-env
  5. DESCRIPTION="Elegant, powerful, clean dock"
  6. HOMEPAGE="https://wiki.go-docky.com"
  7. SRC_URI="https://launchpad.net/${PN}/2.2/${PV}/+download/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="nls"
  12. RDEPEND="
  13. >=dev-dotnet/dbus-sharp-0.8.0:2.0
  14. >=dev-dotnet/dbus-sharp-glib-0.6.0:2.0
  15. || ( >=dev-dotnet/gtk-sharp-2.12.21:2 ( >=dev-dotnet/gnome-sharp-2.24.2:2 dev-dotnet/gconf-sharp:2 dev-dotnet/glib-sharp:2 ) )
  16. >=dev-dotnet/gio-sharp-0.2-r1
  17. dev-dotnet/gkeyfile-sharp
  18. dev-dotnet/gnome-desktop-sharp:2
  19. dev-dotnet/gnome-keyring-sharp
  20. dev-dotnet/gtk-sharp:2
  21. dev-dotnet/mono-addins[gtk]
  22. dev-dotnet/notify-sharp
  23. dev-dotnet/rsvg-sharp:2
  24. dev-dotnet/wnck-sharp:2
  25. "
  26. DEPEND="${RDEPEND}
  27. || ( >=dev-dotnet/gtk-sharp-2.12.21:2 dev-dotnet/gtk-sharp-gapi:2 )
  28. dev-util/intltool
  29. virtual/pkgconfig
  30. "
  31. src_prepare() {
  32. sed -i -e "/warnaserror/d" configure.ac || die
  33. gnome2_src_prepare
  34. eautoreconf
  35. }
  36. src_configure() {
  37. gnome2_src_configure \
  38. --enable-release \
  39. $(use_enable nls)
  40. }