kde-gtk-config-5.9.4.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_TEST="forceoptional"
  5. VIRTUALX_REQUIRED="test"
  6. inherit kde5
  7. DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
  8. HOMEPAGE="https://projects.kde.org/kde-gtk-config"
  9. LICENSE="GPL-3"
  10. KEYWORDS="~amd64 ~arm ~x86"
  11. IUSE="+gtk3"
  12. DEPEND="
  13. $(add_frameworks_dep karchive)
  14. $(add_frameworks_dep kcmutils)
  15. $(add_frameworks_dep kconfigwidgets)
  16. $(add_frameworks_dep kcoreaddons)
  17. $(add_frameworks_dep ki18n)
  18. $(add_frameworks_dep kiconthemes)
  19. $(add_frameworks_dep kio)
  20. $(add_frameworks_dep knewstuff)
  21. $(add_frameworks_dep kwidgetsaddons)
  22. $(add_qt_dep qtgui)
  23. $(add_qt_dep qtwidgets)
  24. dev-libs/glib:2
  25. x11-libs/gtk+:2
  26. x11-libs/libXcursor
  27. gtk3? ( x11-libs/gtk+:3 )
  28. "
  29. RDEPEND="${DEPEND}
  30. $(add_plasma_dep kde-cli-tools)
  31. !kde-base/kde-gtk-config:4
  32. !kde-plasma/kde-gtk-config:4
  33. "
  34. PATCHES=( "${FILESDIR}/${PN}-5.4.2-gtk3-optional.patch" )
  35. src_configure() {
  36. local mycmakeargs=(
  37. -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
  38. -DBUILD_gtk3proxies=$(usex gtk3)
  39. )
  40. kde5_src_configure
  41. }
  42. pkg_postinst() {
  43. kde5_pkg_postinst
  44. einfo
  45. elog "If you notice missing icons in your GTK applications, you may have to install"
  46. elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
  47. elog "for example."
  48. einfo
  49. }