plasma-integration-5.9.4.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. VIRTUALX_REQUIRED="test"
  5. inherit kde5
  6. DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
  7. LICENSE="LGPL-2+"
  8. KEYWORDS="~amd64 ~arm ~x86"
  9. IUSE=""
  10. DEPEND="
  11. $(add_frameworks_dep kcompletion)
  12. $(add_frameworks_dep kconfig)
  13. $(add_frameworks_dep kconfigwidgets)
  14. $(add_frameworks_dep kcoreaddons)
  15. $(add_frameworks_dep ki18n)
  16. $(add_frameworks_dep kiconthemes)
  17. $(add_frameworks_dep kio)
  18. $(add_frameworks_dep kjobwidgets)
  19. $(add_frameworks_dep knotifications)
  20. $(add_frameworks_dep kwayland)
  21. $(add_frameworks_dep kwidgetsaddons)
  22. $(add_frameworks_dep kwindowsystem)
  23. $(add_frameworks_dep kxmlgui)
  24. $(add_plasma_dep breeze)
  25. $(add_qt_dep qtdbus)
  26. $(add_qt_dep qtgui 'dbus' '' '5=')
  27. $(add_qt_dep qtwidgets)
  28. $(add_qt_dep qtx11extras)
  29. x11-libs/libXcursor
  30. x11-libs/libxcb
  31. "
  32. RDEPEND="${DEPEND}
  33. media-fonts/hack
  34. media-fonts/noto
  35. "
  36. # requires running kde environment
  37. RESTRICT+=" test"