mate-power-manager-1.12.1-r2.ebuild 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit mate
  5. if [[ ${PV} != 9999 ]]; then
  6. KEYWORDS="amd64 ~arm x86"
  7. fi
  8. DESCRIPTION="A session daemon for MATE that makes it easy to manage your laptop or desktop"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE="+applet gnome-keyring gtk3 man pm-utils policykit test"
  12. # Interactive testsuite.
  13. RESTRICT="test"
  14. COMMON_DEPEND="app-text/rarian:0
  15. >=dev-libs/dbus-glib-0.70:0
  16. >=dev-libs/glib-2.36:2
  17. >=mate-base/mate-desktop-1.9[gtk3(-)=]
  18. >=sys-apps/dbus-1:0
  19. >=x11-apps/xrandr-1.3:0
  20. >=x11-libs/cairo-1:0
  21. >=x11-libs/gdk-pixbuf-2.11:2
  22. x11-libs/libX11:0
  23. x11-libs/libXext:0
  24. x11-libs/libXrandr:0
  25. >=x11-libs/libnotify-0.7:0
  26. x11-libs/pango:0
  27. applet? ( >=mate-base/mate-panel-1.6[gtk3(-)=] )
  28. gnome-keyring? ( >=gnome-base/libgnome-keyring-3:0 )
  29. !gtk3? (
  30. >=dev-libs/libunique-1:1
  31. >=media-libs/libcanberra-0.10:0[gtk]
  32. >=x11-libs/gtk+-2.24:2
  33. )
  34. gtk3? (
  35. >=dev-libs/libunique-3:3
  36. >=media-libs/libcanberra-0.10:0[gtk3]
  37. >=x11-libs/gtk+-3.0:3
  38. )
  39. pm-utils? ( >=sys-power/upower-pm-utils-0.9.23 )
  40. !pm-utils? ( >=sys-power/upower-0.9.23:= )"
  41. RDEPEND="${COMMON_DEPEND}
  42. policykit? ( >=mate-extra/mate-polkit-1.6 )"
  43. DEPEND="${COMMON_DEPEND}
  44. app-text/docbook-xml-dtd:4.3
  45. >=app-text/scrollkeeper-dtd-1:1.0
  46. app-text/yelp-tools:0
  47. >=dev-util/intltool-0.50.1:*
  48. x11-proto/randrproto:0
  49. >=x11-proto/xproto-7.0.15:0
  50. sys-devel/gettext:*
  51. virtual/pkgconfig:*
  52. man? ( app-text/docbook-sgml-utils:0
  53. >=app-text/docbook-sgml-dtd-4.3 )"
  54. src_prepare() {
  55. mate_src_prepare
  56. # This needs to be after eautoreconf to prevent problems like bug #356277
  57. # Remove the docbook2man rules here since it's not handled by a proper
  58. # parameter in configure.in.
  59. if ! use man; then
  60. sed -e 's:@HAVE_DOCBOOK2MAN_TRUE@.*::' -i man/Makefile.in \
  61. || die "docbook sed failed"
  62. fi
  63. }
  64. src_configure() {
  65. mate_src_configure \
  66. --enable-compile-warnings=minimum \
  67. --with-gtk=$(usex gtk3 3.0 2.0) \
  68. $(use_with gnome-keyring keyring) \
  69. $(use_enable applet applets) \
  70. $(use_enable test tests)
  71. }
  72. src_test() {
  73. unset DBUS_SESSION_BUS_ADDRESS
  74. dbus-launch Xemake check || die "Test phase failed"
  75. }