sil-charis-5.000.ebuild 978 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit font
  5. MY_PN="CharisSIL"
  6. MY_P="${MY_PN}-${PV}"
  7. DESCRIPTION="Serif typeface for Roman and Cyrillic languages"
  8. HOMEPAGE="http://scripts.sil.org/CharisSILfont"
  9. SRC_URI="http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=${MY_P}.zip&filename=${MY_P}.zip -> ${P}.zip
  10. compact? ( http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=CharisSILCompact-${PV}b.zip&filename=CharisSILCompact-${PV}.zip -> ${MY_PN}Compact-${PV}.zip )"
  11. LICENSE="OFL-1.1"
  12. SLOT="0"
  13. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-macos"
  14. IUSE="compact"
  15. DEPEND="app-arch/unzip"
  16. S="${WORKDIR}/${MY_PN}-${PV}"
  17. FONT_S="${S}"
  18. FONT_SUFFIX="ttf"
  19. DOCS="OFL-FAQ.txt documentation/*"
  20. src_prepare() {
  21. if use compact; then
  22. mv "${WORKDIR}"/${MY_PN}Compact-${PV}/*.${FONT_SUFFIX} "${FONT_S}" || die
  23. fi
  24. }