zh-kcfonts-1.05-r3.ebuild 1016 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. S="${WORKDIR}"
  4. inherit eutils font toolchain-funcs
  5. MY_P="kcfonts-${PV}"
  6. DESCRIPTION="Kuo Chauo Chinese Fonts collection in BIG5 encoding"
  7. SRC_URI="ftp://freebsd.sinica.edu.tw/pub/distfiles/${MY_P}.tar.gz
  8. ftp://wm28.csie.ncu.edu.tw/pub/distfiles/${MY_P}.tar.gz
  9. mirror://gentoo/${MY_P}-freebsd-aa_ad.patch.gz"
  10. HOMEPAGE="http://freebsd.sinica.edu.tw/"
  11. # no real homepage exists, but this was written by Taiwanese FreeBSD devs
  12. LICENSE="freedist"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm ia64 ppc s390 sh sparc x86 ~x86-fbsd"
  15. IUSE=""
  16. # Only installs fonts
  17. RESTRICT="strip binchecks"
  18. DEPEND="x11-apps/bdftopcf"
  19. RDEPEND=""
  20. FONT_SUFFIX="pcf.gz"
  21. DOCS="00README Xdefaults.*"
  22. src_unpack() {
  23. unpack ${A}
  24. cd "${S}"
  25. epatch "${WORKDIR}/${MY_P}-freebsd-aa_ad.patch"
  26. epatch "${FILESDIR}/${MY_P}-code-fixups.patch"
  27. epatch "${FILESDIR}/${MY_P}-parallel-make.patch"
  28. }
  29. src_compile() {
  30. emake CC="$(tc-getCC)" || die
  31. }