eog-3.20.5.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit gnome2
  6. DESCRIPTION="The Eye of GNOME image viewer"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome"
  8. LICENSE="GPL-2+"
  9. SLOT="1"
  10. IUSE="debug +exif +introspection +jpeg lcms +svg tiff xmp"
  11. REQUIRED_USE="exif? ( jpeg )"
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
  13. RDEPEND="
  14. >=dev-libs/glib-2.42.0:2[dbus]
  15. >=dev-libs/libpeas-0.7.4:=[gtk]
  16. >=gnome-base/gnome-desktop-2.91.2:3=
  17. >=gnome-base/gsettings-desktop-schemas-2.91.92
  18. >=x11-libs/gtk+-3.19.11:3[introspection,X]
  19. >=x11-misc/shared-mime-info-0.20
  20. >=x11-libs/gdk-pixbuf-2.30.0:2[jpeg?,tiff?]
  21. x11-libs/libX11
  22. exif? ( >=media-libs/libexif-0.6.14 )
  23. introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
  24. jpeg? ( virtual/jpeg:0 )
  25. lcms? ( media-libs/lcms:2 )
  26. svg? ( >=gnome-base/librsvg-2.36.2:2 )
  27. xmp? ( media-libs/exempi:2 )
  28. "
  29. DEPEND="${RDEPEND}
  30. >=dev-util/gtk-doc-am-1.16
  31. >=dev-util/intltool-0.50.1
  32. dev-util/itstool
  33. sys-devel/gettext
  34. virtual/pkgconfig
  35. "
  36. src_configure() {
  37. gnome2_src_configure \
  38. $(usex debug --enable-debug=yes ' ') \
  39. $(use_enable introspection) \
  40. $(use_with jpeg libjpeg) \
  41. $(use_with exif libexif) \
  42. $(use_with lcms cms) \
  43. $(use_with xmp) \
  44. $(use_with svg librsvg)
  45. }