gimageview-0.2.27-r3.ebuild 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # TODO: USE xine could be restored if support for xine-lib-1.2.x
  4. # is patched in wrt #397639
  5. EAPI=4
  6. inherit eutils libtool
  7. DESCRIPTION="Powerful GTK+ based image & movie viewer"
  8. HOMEPAGE="http://gtkmmviewer.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/gtkmmviewer/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~hppa ppc ppc64 x86"
  13. IUSE="mng nls mplayer svg wmf" #xine
  14. RDEPEND="app-arch/bzip2
  15. x11-libs/gtk+:2
  16. >=media-libs/libpng-1.2:0
  17. x11-libs/libXinerama
  18. wmf? ( >=media-libs/libwmf-0.2.8 )
  19. mng? ( media-libs/libmng )
  20. svg? ( gnome-base/librsvg )
  21. mplayer? ( media-video/mplayer )"
  22. #xine? ( media-libs/xine-lib )
  23. DEPEND="${RDEPEND}
  24. nls? ( sys-devel/gettext )
  25. virtual/pkgconfig"
  26. src_prepare() {
  27. # link gimv executable against -lm for floor() and pow()
  28. sed -i -e 's/$(gimv_LDADD)/& -lm/' src/Makefile.in || die #417995
  29. epatch \
  30. "${FILESDIR}"/${P}-sort_fix.diff \
  31. "${FILESDIR}"/${P}-gtk12_fix.diff \
  32. "${FILESDIR}"/${P}-gtk2.patch \
  33. "${FILESDIR}"/${P}-libpng15.patch
  34. # desktop-file-validate
  35. sed -i -e '/^Term/s:0:false:' -e '/^Icon/s:.png::' etc/${PN}.desktop.in || die
  36. elibtoolize
  37. }
  38. src_configure() {
  39. econf \
  40. --disable-imlib \
  41. $(use_enable nls) \
  42. --enable-splash \
  43. $(use_enable mplayer) \
  44. --with-gtk2 \
  45. $(use_with mng libmng) \
  46. $(use_with svg librsvg) \
  47. $(use_with wmf libwmf) \
  48. --without-xine
  49. }
  50. src_install() {
  51. einstall \
  52. desktopdir="${D}"usr/share/applications \
  53. gimv_docdir="${D}"usr/share/doc/${PF}
  54. find "${ED}"usr -name '*.la' -exec rm -f {} +
  55. }