xpaint-2.9.10.3.ebuild 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Image editor with tiff, jpeg and png support"
  6. HOMEPAGE="http://sf-xpaint.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="jpeg2k pgf tiff"
  12. RDEPEND="
  13. media-libs/fontconfig
  14. media-libs/freetype
  15. media-libs/libpng:0
  16. x11-libs/libICE
  17. x11-libs/libX11
  18. >=x11-libs/libXaw3dXft-1.6.2c
  19. x11-libs/libXext
  20. x11-libs/libXft
  21. x11-libs/libXmu
  22. x11-libs/libXpm
  23. x11-libs/libXt
  24. sys-libs/zlib
  25. virtual/jpeg:62
  26. jpeg2k? ( media-libs/openjpeg:0 )
  27. pgf? ( media-libs/libpgf )
  28. tiff? (
  29. media-libs/jbigkit:0
  30. media-libs/tiff:0
  31. )"
  32. DEPEND="${RDEPEND}
  33. sys-devel/flex
  34. sys-devel/bison
  35. virtual/pkgconfig"
  36. src_prepare() {
  37. epatch "${FILESDIR}"/${PN}-2.9.9.4-{QA1,submake,parallel-make}.patch \
  38. "${FILESDIR}"/${PN}-2.9.10.2-{QA2,tiff}.patch \
  39. "${FILESDIR}"/${PN}-2.9.10.3-Fix-build-with-clang.patch
  40. eautoreconf
  41. }
  42. src_configure() {
  43. econf \
  44. $(use_enable tiff) \
  45. $(use_enable jpeg2k libopenjpeg)
  46. }
  47. src_compile() {
  48. # clean up
  49. emake clean
  50. emake -C util clean
  51. # parallel make still fails sometimes
  52. emake substads
  53. emake xpaint.1
  54. default
  55. emake \
  56. WITH_PGF="$(usex pgf "yes" "no")" \
  57. CC="$(tc-getCC)" \
  58. CXX="$(tc-getCXX)" \
  59. -C util
  60. }
  61. src_install() {
  62. default
  63. emake \
  64. WITH_PGF="$(usex pgf "yes" "no")" \
  65. DESTDIR="${ED}" \
  66. -C util install
  67. }
  68. pkg_postinst() {
  69. elog "optional dependencies:"
  70. elog " app-text/gv (external viewer for PostScript output)"
  71. elog " media-gfx/imagemagick (external viewer for pixel graphics)"
  72. elog " net-print/cups (printing)"
  73. }